这篇文章上次修改于 279 天前,可能其部分内容已经发生变化,如有疑问可询问作者。

  • 当两条ISP链路接入防火墙时,可以起到提高总带宽、链路冗余和负载均衡的作用
  • 通过链路聚合提高总带宽,通过配置路由策略实现链路负载均衡
  • 防火墙三种模式:路由模式、透明模式、混合模式。有IP地址并通过第三层对外连接是路由模式。未配置IP地址并通过第二层对外连接是透明模式。两种模式混合为混合模式。
  • FC-SAN用的FC光纤连接,IP-SAN采用IP网络传输
  • RAID 0
    RAID 0

优点:最大提升存储性能和存储空间。缺点:没有校验和备份,无法容错,有一块硬盘损坏就无法使用。

  • RAID 1
    RAID 1

优点:只要有一块磁盘可用就能正常工作,安全性很高,读取数据效率高。缺点:磁盘利用率低,写入数据效率降低。

  • RAID 2
    RAID 2

以位(bit)为单位存储,采用海明码对数据进行校验和恢复。
优点:一块硬盘损坏能够对未损坏的硬盘进行运算还原已损坏的数据,以实现数据恢复,对大数据量的读写有很高的性能。缺点:少量数据的读写性能不好。

  • RAID 3
    RAID 3

参考RAID 2读写原理,数据单位为字节。

  • RAID 4
    RAID 4

和RAID 2原理类似,仅数据分割单位不同。

  • RAID 5
    RAID 5

以块为单位同步式分别存储在不同硬盘上,并对数据进行海明码运算,海明码会写入不同的磁盘。磁盘利用率为n-1,读写性能高。

  • RAID 10
    RAID 10

RAID 1+0:RAID 1和RAID 0的结合。优点:继承了RAID 0的快速与高效,继承了RAID 1的数据安全。缺点:继承了RAID 0和RAID 1的一些缺点,磁盘利用率很低,只有50%。

  • RAID 01
    RAID 01

一个硬盘损坏,同组RAID 0所有硬盘都会停止运作。
RAID比较

  • 端口数据流量异常一般可能的故障是感染病毒,采取安装杀毒软件查杀病毒的方法
  • CIFS和NFS为网络文件系统常用的两种协议,CIFS常用于Windows,NFS常用于Linux
  • 为安装Web服务DNS服务,必要的组件有网络服务应用程序服务器
  • IIS创建网站时,网站访问权限中勾选读取运行脚本执行
  • DNS启用循环功能后,同一个域名可以对应多个IP地址
  • DNS属性中勾选禁用递归时,DNS服务器会使用迭代查询模式
  • DNS网络掩码排序和循环功能同时被选用时,网络掩码模式优先级更高

  • 在路由器上定义NAT,对内网地址进行了有效的屏蔽,也起到了节省公网地址的作用。
  • 常用的IP访问控制列表有两种,他们是编号为1~99和1300~1399的标准访问控制列表和100~199和2000~2699的扩展访问控制列表。
  • 标准访问控制列表依据源IP对IP报文进行过滤,扩展访问控制列表依据源IP、目标IP、上层协议和时间等对IP报文过滤。标准访问控制列表放置在靠近目标地址位置,扩展访问控制列表放在靠近源地址位置。
  • R1(config-if) #ip access-group 1 out #out为定义出接口方向
  • 客户机和“首选DNS服务器”地址必须与该DNS服务器地址一致这句话是错误的。
  • 除了主机头的方式,还可以采用网卡绑定多个IP地址的方法在一台服务器上配置多个网站。
  • 1394网络适配器能连接数码设备、大容量硬盘等设备

  • IP SAN采用以太网技术互连。
  • 单播、组播、广播。单播在发送和每个接收主机之间需要单独的数据信道。组播允许一个或多个主机发送一个数据包到多个主机的网络技术。广播是在IP子网内发送广播包,子网内的主机都能接收到数据包
  • 下午题里很多网管解决方案一般都不包括防病毒模块
  • ACL使用包过滤技术达到访问控制目的。
  • line vty 0 4 对VTY端口进行设置
  • 活动日志格式中,ODBC日志记录需要提供用户名密码
  • FTP匿名用户的权限在"本地用户和组"的权限相同,FTP可以设置多个虚拟目录。
  • switchport mode trunk 交换机端口设置为trunk模式
  • router rip 设定路由为rip
  • 局域网地址使用非主类地址需要用RIPv2才能正确宣告路由。
  • 三层交换机上接口模式为auto模式时,无法直接将接口设置为中继trunk模式,需要先手动配置为access模式,然后再设置为中继模式。

  • 两台计算机通过IPsec协议通信必须先协商,协商结果成为SA,IKE将协商工作分为两个阶段,第一阶段是协商主模式SA,建立一个安全的经过身份验证的通信信道,之后第二阶段建立快速模式SA,便可以通过安全信道通信。
  • [RouterA] interface tunnel 0/0/1 //创建隧道接口
  • [RouterA-Tunnel0/0/1 ] tunnel-protocol ipv6-ipv4 tunnel-auto //指定 Tunnel 为自动隧道模式

  • OSPF主要用于大型、异构的IP网络中,是对链路状态路由的一种实现。
  • 对汇聚层两台交换机的F0/3、F0/4端口进行端口聚合,两端口默认模式为access模式,进行聚合时应配置为trunk模式。
  • 为了在汇聚层交换机上实现虚拟路由冗余功能,需配置虚拟路由冗余协议
  • 备份路由设备长时间没有收到主路由设备发送的组播报文,则将自己的状态转为Master
  • 为了避免二层广播风暴,应在接入层与汇聚层配置MSTP
  • 汇聚交换机的VLAN的standby默认优先级是100。VLAN设置preempt的含义是保证设备故障恢复后正常工作
  • Linux中DHCP的配置文件是dhcpd.conf
  • ipconfig /release 释放当前地址
  • ipconfig /renew 重新从DHCP申请IP
  • Internet共享打印使用的协议是IPP
  • Active Server Pages设置为允许意为可采用页面显示打印机信息
  • 以太信道技术起到了增加带宽、负载均衡和链路冗余的作用
  • 两个交换机是否形成以太信道可以用协议自动协商,两种协议一种是端口聚合协议(PAgP),另一种是链路聚合控制协议(LACP)
  • description wgsw-g0/1 //给端口做备注
  • no switchport //关闭二层交换机的功能,启动三层路由模式
  • no ip domain lookup //关闭域名解析
  • interface port-channel 10 //创建编号为10的port-channel接口
  • channel-group 10 mode on //分配接口指定PAgP模式
  • ip router 0.0.0.0 0.0.0.0 192.168.102.1 //配置默认路由
  • ip routing //开启该交换机的三层路由功能
  • ip dhcp snooping //开启DHCP侦听功能
  • ip dhcp snooping trust //设定端口为信任端口

  • DHCP分配IP使用的是广播方式
  • 子网2要使用子网1的DHCP不可使用IP代理的方式
  • DHCP租借期过去50%时,客户端会发送DHCP REQUEST延期

AR2200

  • 两条链路接入Internet。ISP2是PPPOE链路

    detect-group 1
    detect-list 1 ip address 142.1.1.1
    timer loop 5
    ip route-static 0.0.0.0 0.0.0.0 Dialer 0 preference 100
    ip route-static 0.0.0.0 0.0.0.0 142.1.1.1 preference 60 detect-group 1

  • 综上所述,用户默认通过ISP1访问Internet,该配置片段实现网络功能是网络冗余备份
  • 常见的无线网络安全隐患有IP地址欺骗、数据泄露、非授权用户接入、非法入侵、网络通信被窃听等
  • 防火墙用于实现核心业务区域边界防护,用户上网行为管理器用于实现无线用户上网行为管控,IDS(入侵检测系统)用于分析检测入侵行为,加强安全认证可以配置IEEE802.1x的RASIUS认证。
  • RAID2.0相对于RAID1.0的区别与优势:基于硬盘来做RAID的就是RAID1.0,基于硬盘的大块Chunk来做RAID的就是RAID2.0;RAID2.0能够显著减少重构时间,避免重构时对一块磁盘的高强度读写,降低硬盘故障率
  • 向DNS服务器发出请求后没有得到解析结果,则使用NETBIOS名字解析
  • ipconfig -displaydns 显示当前DNS
  • ipconfig -flushdns 刷新DNS
  • dhcp select golbal 接口工作在地址池模式
  • gate-list 10.10.1.1 设置默认网关
  • lease day 30 hour 0 minute 0 设置dhcp租用期限

  • 点到点环境下,IPSec VPN隧道需要明确源IP地址目的IP地址
  • TTL值与路由器跳数的关系:源地点TTL起始值(比返回的TTL值略大的一个2的乘方数)-返回时的TTL值[例如128-122=6]